<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":920,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81710447-1', 'auto');
</script>

<script>
dataLayer = [];
</script>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-74c0340099b3ec93e18951b2b059a74493c5db2e72ef7acd1cf1c42a6e4a523d.css' rel='stylesheet'>
<title>HickoryHusker  -  Indiana Basketball HOF announces 60th Men’s Induction Class</title>
<meta content='HickoryHusker  -  Indiana Basketball HOF announces 60th Men’s Induction Class' property='og:title'>
<meta content='NEW CASTLE, Ind. – Encompassing basketball successes that began in our state but include accomplishments with national..' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-c1736e939bc473b9586dcc654ec6b77fbdf22408de27c92ab17e25a9018765dc.css" />


<script src="https://cdn.rivals.com/production/assets/lib-00d15204fcb30534f67334e4fce0a1a9f44edf9ebabd3d87c2d49d860babf7fa.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-a0e9b51a2c11123c37789d738dc9139390db3795d7afff9e98b2cb090a7bc4a0.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="57vA7m5duBog60GQk9fdDszGzVft3caew3MpfnupVspd19BILF+6Yiqp/Hsn8ETZFL1ZpYtqtQjcnTg65jpKgQ==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://hickoryhusker.rivals.com/news/indiana-basketball-hof-announces-60th-men-s-induction-class' property='og:url'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/rukyo3lsi6hpolwhspwi' property='og:image'>
<meta content='NEW CASTLE, Ind. – Encompassing basketball successes that began in our state but include accomplishments with national..' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2021-11-30 09:04:05 -0600' property='article:published_time'>
<meta content='2021-11-30 09:04:06 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='hickoryhusker.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='hickoryhusker contents-show' ng-app='rivals'>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81710447-1', 'auto');
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .hickoryhusker #programming > h1 {
      background-color: #850010 !important; } }
  
  .hickoryhusker .wrapper-container .team-colors-line {
    background-color: #FEC100; }
  
  @media screen and (min-width: 768px) {
    .hickoryhusker .solid-team-line {
      width: 100%;
      height: 8px;
      display: flex;
      background-color: #FEC100; } }
  
  .hickoryhusker .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #850010; }
    .hickoryhusker .team-colors-line .color {
      width: 33.33%; }
    .hickoryhusker .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .hickoryhusker .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .hickoryhusker .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .hickoryhusker .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .hickoryhusker .team-colors-line.header {
      height: 6px; }
  
  .hickoryhusker > header .notification-link .count-container {
    background-color: #850010 !important; }
  
  .hickoryhusker > header .wrapper-container {
    background-color: #850010 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
  
  .hickoryhusker > header .invalid-email-banner {
    background-color: #850010;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .hickoryhusker > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .hickoryhusker > header .invalid-email-banner a:hover {
      color: #FEC100; }
  
  @media screen and (max-width: 767px) {
    .hickoryhusker > header .mobile-header {
      background-color: #FEC100 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .hickoryhusker > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .hickoryhusker > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .hickoryhusker > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .hickoryhusker > header .nav-row > ul,
    .hickoryhusker > header .third-nav {
      background-color: white !important; }
    .hickoryhusker > header .dropdown-toggle > i.fa {
      color: #850010 !important; } }
  
  .hickoryhusker > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #850010; }
  
  .site-primary-font-color {
    color: #850010; }
  
  .site-primary-background-color {
    background-color: #850010; }
  
  .site-secondary-font-color {
    color: #FEC100; }
  
  .site-secondary-background-color {
    background-color: #FEC100; }
  
  :root {
    --primary-color: #850010;
    --primary-color-overlay: rgba(133, 0, 16, .4);
    --secondary-color: #FEC100;
    --accent-color: #850010;
    --button-color: #850010;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("Hickoryhusker")' role='navigation'>
<div class='wrapper-container'>
<a class='cta-header-banner' ng_href='{{ctrl.subscribePath}}' style='display: none;'>
Enjoying HickoryHusker? Get a yearly subscription for $99.95/year or $9.95/month
</a>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Indiana HS Sports" class="site-header logo-image-wrapper" href="https://hickoryhusker.rivals.com/"><img src="https://images.rivals.com/image/upload/f_auto,q_auto/hnvusdwoykjzj93ek6gc" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
<div class='solid-team-line header'></div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://hickoryhusker.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;hickoryhusker&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://hickoryhusker.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;hickoryhusker&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid3.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022719654' type='text/javascript'></script>

<rv-content-title content-title='Indiana Basketball HOF announces 60th Men’s Induction Class' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='HickoryHusker' name='twitter:site'>
<meta content='Indiana Basketball HOF announces 60th Men’s Induction Class' name='twitter:title'>
<meta content='NEW CASTLE, Ind. – Encompassing basketball successes that began in our state but include accomplishments with national..' name='twitter:description'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rukyo3lsi6hpolwhspwi' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:52,&quot;legacy_id&quot;:938,&quot;name&quot;:&quot;HickoryHusker&quot;,&quot;friendly_name&quot;:&quot;Indiana HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;hickoryhusker&quot;,&quot;primary_color&quot;:&quot;850010&quot;,&quot;secondary_color&quot;:&quot;FEC100&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;Hickoryhusker&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81710447-1&quot;}, true, 87, nil, {&quot;id&quot;:4,&quot;primary_color&quot;:&quot;850010&quot;,&quot;secondary_color&quot;:&quot;FEC100&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:false,&quot;rivals_module_football&quot;:false,&quot;header_name&quot;:&quot;HickoryHusker.com&quot;,&quot;header_logo_cloudinary&quot;:&quot;hnvusdwoykjzj93ek6gc&quot;,&quot;mobile_header_logo_cloudinary&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81710447-1&quot;,&quot;logo_background_shading&quot;:&quot;white&quot;,&quot;football_content&quot;:false,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:false,&quot;other_content&quot;:false,&quot;site_id&quot;:52,&quot;created_at&quot;:&quot;2016-11-23T13:38:41.283-06:00&quot;,&quot;updated_at&quot;:&quot;2021-04-16T12:39:37.062-05:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:false,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:true,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:2},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://hickoryhusker.forums.rivals.com&quot;,&quot;scoreboard_scores_id&quot;:null,&quot;scoreboard_photos_id&quot;:null,&quot;aol_player_id&quot;:null,&quot;aol_company_id&quot;:null,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:false,&quot;display_fb_follow&quot;:false,&quot;follow_twitter_handle&quot;:null,&quot;follow_fb_handle&quot;:null,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:7,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:&quot;solid&quot;,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;,&quot;navigation_key&quot;:&quot;hickoryhusker&quot;},
&quot;58e686759efa8936610b8215&quot;, &quot;58e68374c7480e728bcc385f&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:94,&quot;user_id&quot;:1063,&quot;site_id&quot;:52,&quot;updated_at&quot;:&quot;2017-08-09T20:52:52.696-05:00&quot;,&quot;publisher_name&quot;:&quot;Leigh  Evans&quot;,&quot;first_name&quot;:&quot;Leigh &quot;,&quot;last_name&quot;:&quot;Evans&quot;,&quot;site_title&quot;:&quot;Editor/Publisher&quot;,&quot;bio&quot;:&quot;&quot;,&quot;twitter_handle&quot;:&quot;HickoryHusker&quot;,&quot;image_url&quot;:&quot;https://images.rivals.com/image/upload/f_auto,q_auto,t_author_bio/hxodgwbjpkwkp5ssi9uc&quot;,&quot;publisher_name_and_title&quot;:&quot;Leigh  Evans, Editor/Publisher&quot;,&quot;site_name&quot;:&quot;HickoryHusker&quot;,&quot;site_short_name&quot;:&quot;Hickoryhusker&quot;,&quot;has_edited_profile&quot;:true}, null)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='HickoryHusker'></rv-news-ticker>
</div>

<rv-forums ad-referer='https://hickoryhusker.rivals.com/news/indiana-basketball-hof-announces-60th-men-s-induction-class' base-api-url='https://Hickoryhusker.forums.rivals.com/' forums-url='https://hickoryhusker.forums.rivals.com' homepage='false' pub-ad='{&quot;id&quot;:95,&quot;image_id&quot;:1809930,&quot;url&quot;:&quot;http://www.superhoopsplus.com/&quot;,&quot;position&quot;:2,&quot;site_id&quot;:52,&quot;created_at&quot;:&quot;2016-02-22T15:14:10.965-06:00&quot;,&quot;updated_at&quot;:&quot;2017-03-15T11:34:42.682-05:00&quot;,&quot;image_url&quot;:&quot;https://images.rivals.com/image/upload/f_auto,q_auto,t_ad/hngbylfazfdq1koq9yrb&quot;}' size='size' space-id='2022719654' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='mobile-ad native-ad-ccc25e1a-d33c-46c9-a14a-96144b7a8b28'></div>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://hickoryhusker.rivals.com/news/indiana-basketball-hof-announces-60th-men-s-induction-class/printable' site-name='HickoryHusker'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2021-11-30 09:04:05 -0600&#39;) }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2343732/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Indiana Basketball HOF announces 60th Men’s Induction Class</h1>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://images.rivals.com/image/upload/f_auto,q_auto,t_author_bio/hxodgwbjpkwkp5ssi9uc'>
<div>
<span class='author-name'>
Leigh  Evans
&bull;
<span class='type-sm'>HickoryHusker</span>
</span>
<div>
<span class='author-name'>Editor/Publisher</span>
</div>
<div class='type-sm'>
<a href='//twitter.com/HickoryHusker' target='_blank'>@HickoryHusker</a>
</div>
</div>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/HickoryHusker'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>

<div class='mobile-ad'>
<div class='native-ad-50d38545-0eeb-4c35-9393-b22cf70b9e3d'></div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p> <b>NEW CASTLE, Ind. –</b> Encompassing basketball successes that began in our state but include accomplishments with national and international scope, the board of directors of the Indiana Basketball Hall of Fame announces their 60th induction class, to be honored in ceremonies in 2022. </p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rukyo3lsi6hpolwhspwi&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/rukyo3lsi6hpolwhspwi&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Connersville&#39;s Al Brown drives ball in 1959 Sectional." src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rukyo3lsi6hpolwhspwi" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Connersville&#39;s Al Brown drives ball in 1959 Sectional.</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>The late <b>Jerry Bass</b> was the state’s leading scorer in 1958 and an Indiana All-Star before playing at Indiana University. Setting the Morristown High School career scoring record at 1,652 points, he averaged a state-best 30.1 points per game as a senior and earned selection to the Indiana All-Star squad. A high scorer throughout his career, he averaged 23.9 points as a junior for the Yellow Jackets’ 23-2 team and 19.0 points per game as a sophomore. Playing at IU under Branch McCracken, he totaled 632 points in 68 career games, including averaging 11.9 per game as a senior in 1961-62. He died in 2009.</p><p><b>Wayne Boultinghouse </b>scored over 1,100 points at Rockport High School, averaging over 18 points per game as a senior for their 18-5 team. Playing five sports at the University of Evansville, he was a senior captain of the Aces’ 26-3 1964 NCAA College Division National Championship team and participating in the 1964 Olympic Trials. Returning to his alma mater from 1969-1974, he was assistant coach for the Aces’ 1971 national championship squad. From 1974-1981, he served as athletic director and head men’s basketball coach at the University of Southern Indiana, assisting in the formation of the Great Lakes Valley Conference. From 1986-1996, he had a .741 winning percentage as head coach and AD at Kentucky Wesleyan, earning national Coach of the Year honors in 1992. He completed his coaching career as head coach of the South Spencer High School girls basketball program from 1996-2002. He resides in Owensboro, Kentucky.</p><p><b>Napoleon Brandford</b> was starting center for the 1970 East Chicago Roosevelt state championship team. A senior member of the 28-0 championship team, it was the third consecutive undefeated regular season for the Rough Riders, compiling a 71-2 record over three seasons. Attending the University of Nevada, he earned freshman All-American honors. He averaged 15.2 points and 10.8 rebounds as a sophomore before a torn Achilles tendon injury. He completed his degree at Purdue Calumet before forging a career in finance. As a co-founder of Siebert, Brandford, Shank, Inc, he was chairman of the largest minority-owned investment firm on Wall Street. He was a lead investor in the Gary Steelheads of the CBA and served from 1998-2014 on the NCAA Corporate Advisory Board. He resides in Berkeley, California.</p><p><b>Al Brown</b> began his noted coaching career with Indiana roots. A 1959 graduate of Connersville High School, he was a three-year letterwinner at Purdue University and was later on Purdue’s staff when they reached the 1969 NCAA national championship game. The highlight of his high school coaching career at Centerville, Lafayette Central Catholic and DeKalb was leading LCC to a 1973 sectional championship, ending Lafayette Jeff’s state record of 29 straight sectional titles. At Ball State, he was head coach of the Cardinals’ 1986 MAC champions and NCAA Tournament team. A men’s assistant at Ball State, Western Michigan, Minnesota and Tennessee, in 1995 he was hired as an assistant by Pat Summitt with the University of Tennessee Lady Vols, where he was on the bench for three women’s NCAA national championship teams. Also assisting the women’s programs at Wisconsin, South Carolina, Michigan State and Duke, he has been a part of teams reaching 8 NCAA Final Fours, 24 NCAA Tournaments and winning 80% of their games. He is the only coach in college basketball history to coach in both the NCAA Division I men’s and women’s national championship games. He resides in Knoxville, Tennessee.</p><p>The late <b>Garth Cone</b> attained small school success as the noted coach of Alexandria High School. Leading the Tigers’ program from 1977 until his untimely death in 2010, Cone’s teams won 419 games (61%), along with 16 Central Indiana Conference titles, five sectionals, three regionals, a semi-state and the 1998 IHSAA 2A championship. Three of his team’s sectional titles (1989, 1994 and 1995) came in the one-class state tournament played at Anderson, each of them with small-school Alexandria knocking out the host Indians. An assistant coach of the 1995 Indiana All-Stars, he served as President of the Indiana Basketball Coaches Association. He was a 1965 graduate of Pierceton High School and a 1969 graduate of Taylor University, where he played under Hall of Fame coach Don Odle.</p><p><b>Gary Duncan </b>made his mark on southern Indiana basketball. A 1963 graduate of Oakland City High School and 1967 graduate of Oakland City College, he spent 21 seasons as head coach at Salem and Southridge high schools. Highlighting his 19 years and 279 wins at Southridge were 1985 and 1986 state finals appearances – the 1985 team was the only team in one-class state finals history to reach the final four with no seniors. His two-year stint at Salem to begin his career included a 20-6 season with 1971 sectional and regional championships in his first season as a head coach. In all, his teams won 303 games (.627), eight sectionals, three regionals and two semi-states. He resides in Huntingburg</p><p>The late <b>Tony Etchison</b> was a four-year varsity starter at Noblesville High School, where he scored 1,357 career points and led Noblesville to three consecutive sectional titles in 1989, 1990 and 1991. Named all-county four years, all-sectional and all-regional three years, all-conference, all-Indianapolis Metro and 1990 and 1991 Hamilton County Player of the Year, he averaged 22.8 points, five rebounds and four assists per game as a senior. On scholarship at Mercer University, he was a two-year starter earning all-academic honors four years and led the TransAmerican Conference in three-point shooting. He died of a farming accident in 2019 at the age of 47.</p><p><b>Jerry Flake </b>earned all-state accolades in high school and All-American honors in college. Scoring over 1,100 points at Washington High School, he averaged 21.5 points per game as a senior in 1964-65. At Southwestern Louisiana, he totaled 2,058 career points earning 1967 NAIA All-American honors and 1968 and 1969 Small College All-American recognitions, while hitting 50.5% FG and 85.4% FT for his career. Showcasing his shooting prowess, he won both of the Great Indiana Shootout contests held at the New Castle Fieldhouse in 1986 and 1987, beating out numerous Indiana Basketball Hall of Fame inductees. Involved in teaching and coaching in Louisiana, Illinois, and North Daviess and Hagerstown high schools, he has been inducted into the Louisiana Basketball Hall of Fame and Southwestern Louisiana Athletics Hall of Fame. He resides in Florida.</p><p><b>Ray McCallum</b> has one of the most decorated careers as an Indiana high school and college player and Indiana college coach. A member of Muncie Central’s 1978 state championship team and starter for their 1979 state title squad, he hit 17 of 20 field goals in the 1979 state finals to earn MVP honors of the tournament. His career at Ball State University resulted in school and Mid-American Conference career scoring records at 2,109 points. The 1983 MAC Player of the Year after averaging 20.7 points per game, he won the Frances Pomeroy Naismith Award, recognizing the best college player in the nation under 6’0” and his #10 jersey has been retired at Ball State. As the head coach at Ball State from 1993-2000, he led the Cardinals to 126 wins (.624), a MAC regular season title, two MAC Tournament championships and two NCAA Tournament appearances. Including tenures at the University of Houston and the University of Detroit, he has 300 wins, three NCAA Tournament appearances and three NIT appearances in 19 seasons. He is currently an assistant coach at Tulane University.</p><p><b>Gary Merrell</b> achieved success throughout Indiana during his career. A 1964 graduate of Northwestern High School, he averaged 20.2 points as a senior for the Tigers’ 16-6 squad. Surpassing 1,000 career points at the University of Findlay, he was also recognized off the court for scholarship, leadership and citizenship and was a 1996 inductee in their athletics hall of fame. An Indiana high school coach for 36 seasons at Carroll, Madison, Seymour, DeKalb, Heritage, Fort Wayne Blackhawk Christian and Fort Wayne Smith Academy, his teams registered 482 wins, 10 sectional championships, four regional titles and a 2004 1A runner-up finish (Blackhawk Christian). He remains employed in education and resides in Fort Wayne. </p><p><b>Doug Mitchell</b> established North Central (Indianapolis) High School as a state power. In 25 seasons leading the Panthers, his teams won 428 games (71%) and a pair of IHSAA 4A championships while coaching nine Indiana All-Stars and four All-Americans. Leading the North Central program from 1992-2018, Mitchell’s teams claimed four MIC conference titles, four Marion County Tournament championships, won 11 sectionals, four regionals, and three semi-states, claiming 1999 and 2010 4A championships and 2007 4A state runner-up. He coached four Indiana Mr. Basketball winners (Jason Gardner, AJ Ratliff, Eric Gordon and Kris Wilkes) each who were recognized as McDonald’s All-Americans. Mitchell was an assistant coach in the 2003 McDonald’s All-American game, an assistant for USA Basketball multiple times and head coach of the 2008 Gold Medal USA Basketball Junior National Team. Prior to his coaching success, he was a standout as a player at Hamilton Heights High School, where he totaled 1,167 career points, was the 1975 Hamilton County Player of the Year and led the Huskies to a 1975 sectional championship, the first for the school in 35 years. A scholarship player at Butler University, he received the Hilton U. Brown Mental Attitude as a senior in 1979. He resides in Fishers.</p><p><b>Craig Neal</b> has been involved in the game at every level starting with his time at Washington High School. A 1983 Indiana All-Star after averaging 27.6 points per game and leading his 25-2 team to the semi-state finals, he totaled 1,440 points in his Hatchets career. At Georgia Tech, he set school records of 127 games played and 570 career assists as part of three NCAA Tournament teams and set the Yellow Jackets’ single-season assist record of 303 his senior year. Drafted in the 3rd round of the 1988 NBA Draft, he played with Portland, Miami and Denver and also spent time in the WBL and CBA, including the Fort Wayne Fury. A scout and assistant coach with the Toronto Raptors from 1994-2003, he was an assistant at the University of Iowa and University of New Mexico, was head coach of New Mexico from 2013-2017 and currently is associate head coach at the University of Nevada. </p><p><b>Matt Painter</b> has earned national acclaim during his tenure as head men’s basketball coach at Purdue University. In his 17th season as head coach in West Lafayette, the Boilermakers have five Sweet 16 appearances, 12 NCAA Tournament berths, three Big Ten regular-season championships and a Big Ten Tournament title. Entering the 2021-22 season, he is the 3rd winningest coach in Purdue history with a 355-184 (.659) mark and a career 380-189 (.668) record, including one season leading Southern Illinois. At the time of this announcement (Nov. 30, 2021), his team is ranked #2 in the nation, tying the highest ranking in Purdue basketball history. The 2019 NABC National Coach of the Year, he has been named the Big Ten Coach of the Year more than any other active coach, receiving the recognition four times. Painter is a 1994 graduate of Purdue, he was a senior captain and remains among the program leaders in career assists. His prep career at Delta High School included school records in career scoring (1,497) and assists. As a senior, he set Delta’s record for single-season scoring, averaging 27.7 points along with 9.6 rebounds and 7.4 assists per game, leading the Eagles to a 21-4 record, a sectional championship and his selection as a 1989 Indiana All-Star. </p><p>The late <b>William R. “Bill” Smith</b> became synonymous with Broad Ripple High School basketball during his 24 seasons as head coach of the Rockets, including their 1980 state championship victory. The two-time Marion County Coach of the Year and 1980 Indiana All-Star coach, his teams won 250 games, three sectionals, two regionals and one semi-state. He coached five Indiana All-Stars, including future NBA players Mike Woodson and George Hill and he was the first Black coach to lead an integrated school to an Indiana high school basketball state championship. Following his tenure at Broad Ripple, he served as a consultant to John Calipari at the University of Memphis and University of Kentucky and assisted Mike Woodson with the New York Knicks and Atlanta Hawks until his death in 2014.</p><p>The late <b>James Strickland</b> was a standout in the early years of the 20th century. At Owensville High School in Posey County, he was key to their first sectional championship team, reaching the 1925 regional finals before a loss to eventual state runner-up Vincennes Lincoln. As a senior, he again led the Kickapoos to a sectional championship and again was beaten in the regional by the eventual state runner-up squad, Evansville Central, by a 23-22 margin. At Indiana University, he enrolled with classmate Branch McCracken and that duo led the Hoosiers in scoring as sophomores in the 1927-28 season, going 15-2 and tying for the Big Ten championship – the 2nd in school history. He again was a leading scorer his junior year, garnering his 2nd consecutive All-Big Ten recognition, named to the 1929 Indiana all-college team and 1929 3rd team All-American honors. He was the captain and leading scorer of the New York Athletic Club of the AAU league for five seasons and played briefly with the Indianapolis Kautskys, alongside John Wooden. Strickland died in 1997.</p><p><b>John Sherman Williams</b> sprung an all-star high school career at Indianapolis Washington into an All-American college career at Indiana State. Averaging over 21 points and nine rebounds per game as a high school sophomore, his averages climbed to 27.3 points and 10.6 rebounds by his senior year, leading to recognition as a 1982 Indiana All-Star. Along the way, he led the Continentals to a sectional championship in 1980 before a loss to eventual state champ Broad Ripple and reached the 1982 regional finals before a one-point loss to state finalist Cathedral. His senior season, he was the Indianapolis city scoring champion. A stellar career at Indiana State University culminated with 2,370 career points, leading the Sycamores in scoring each of his four seasons and earning Missouri Valley Conference all-conference recognition four times and All-American honors three times. His senior season, he tied Larry Bird’s ISU record of 81 consecutive games in double-figure scoring, was 5th in the country in scoring at 25.4 points per game and graduated 2nd in Indiana State career scoring. He completed his college career 3rd in career scoring in the history of the Missouri Valley Conference, trailing only Oscar Robertson and Larry Bird and in 2007 was named one of the 50 greatest players in MVC history. Employed at Heritage Christian School, he resides in Fishers.</p><p>The late <b>Clarence Walker</b> was the first Black player to participate in a national collegiate basketball tournament game. A 1946 graduate of East Chicago Washington High School under Hall of Fame coach John Baratto, he was a key member of their 24-3 regional championship team that season. Recruited by John Wooden to Indiana State Teachers College, he was a member of their 1947 team that was invited to the NAIB national tournament. On the basis that a Black player would not be eligible to compete in that tournament, Indiana State declined their invitation. A year later, the rules had been altered and with Walker permitted to play, the Indiana State squad finished as national runners-up in the 1948 NAIB tournament. As a senior, Walker was a starting guard as the Sycamores won the 1950 NAIB National Championship, following a 1949 national semi-finals appearance. Receiving numerous awards, including the Purple Heart for his service in the Korean War, he was a teacher, counselor and administrator in Gary Schools for 35 years, rising to Assistant Superintendent. He died in 1989 at the age of 60.</p><p><b>Mark Baltz</b> is the recipient of the 2022 Silver Medal Award for contributions to Indiana basketball other than as an Indiana high school player or Indiana high school coach. Officiating Indiana high school basketball for 43 years and a sports official for 50 years, he worked Indiana high school basketball games from 1971– 2013. Baltz was the 2005 recipient of the IHSAA &amp; NFOA Basketball Official of the Year recognition, the 2011 recipient of the IBCA Roy Gardner Award and 2013 recipient of the Indiana Basketball Hall of Fame Center Circle Officials Award. He worked 38 sectionals, 26 regionals, six semi-states and three boys basketball state finals. His officiating career also included 15 seasons in men’s college basketball and 13 seasons of women’s college basketball. He is a lifetime member and Past President of the Indiana Officials Association and a lifetime member and current President of the Indiana Basketball Hall of Fame. Also noted for his football officiating career, he is a retired National Football League head linesman of 25 years and recipient of the 2021 NFLRA “Referee of the Year” award. A 1966 graduate of Lancaster (OH) High School and 1970 graduate of Ohio University, he and his wife Nicki reside in Zionsville.</p><p>The Indiana Basketball Hall of Fame’s 60th Men’s Awards Banquet are planned for Wednesday, March 23, 2022. The day’s events will include a reception at the Indiana Basketball Hall of Fame museum in New Castle that afternoon with a banquet that evening at the Primo Banquet Hall in Indianapolis.</p><p>Reservations will soon be available online or through mail order in early 2022. Call the Hall at 765-529-1891, visit <a href="https://hoopshall.com/indiana-basketball-hof-announces-60th-mens-induction-class/">www.hoopshall.com</a> or email <a href="mailto:info@hoopshall.com">info@hoopshall.com</a> for more information.</p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://hickoryhusker.rivals.com/news/indiana-basketball-hof-announces-60th-men-s-induction-class/printable' site-name='HickoryHusker'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='{&quot;id&quot;:95,&quot;image_id&quot;:1809930,&quot;url&quot;:&quot;http://www.superhoopsplus.com/&quot;,&quot;position&quot;:2,&quot;site_id&quot;:52,&quot;created_at&quot;:&quot;2016-02-22T15:14:10.965-06:00&quot;,&quot;updated_at&quot;:&quot;2017-03-15T11:34:42.682-05:00&quot;,&quot;image_url&quot;:&quot;https://images.rivals.com/image/upload/f_auto,q_auto,t_ad/hngbylfazfdq1koq9yrb&quot;}' display-lrec1-rightrail='true' display-lrec2-rightrail='true' display-lrec3-rightrail='true' enrichments='[{&quot;active&quot;:true,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:2}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2021' ncaaf-schedule-year='2021' site='{&quot;id&quot;:52,&quot;legacy_id&quot;:938,&quot;name&quot;:&quot;HickoryHusker&quot;,&quot;friendly_name&quot;:&quot;Indiana HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;hickoryhusker&quot;,&quot;primary_color&quot;:&quot;850010&quot;,&quot;secondary_color&quot;:&quot;FEC100&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;Hickoryhusker&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81710447-1&quot;}' twitter-feed='{&quot;id&quot;:52,&quot;site_id&quot;:52,&quot;handle&quot;:&quot;HickoryHusker&quot;,&quot;list_name&quot;:&quot;hoosier-hysteria&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:24:56.924-06:00&quot;,&quot;updated_at&quot;:&quot;2017-03-08T15:02:09.496-06:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[&quot;HickoryHusker&quot;],&quot;max_number&quot;:6}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://hickoryhusker.rivals.com/news/indiana-basketball-hof-announces-60th-men-s-induction-class/printable' site-name='HickoryHusker'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Fhickoryhusker.rivals.com%2Fnews%2Findiana-basketball-hof-announces-60th-men-s-induction-class&amp;space_id=2022719654' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-basketball,content-basketball-free,content-article' title='Indiana Basketball HOF announces 60th Men’s Induction Class'></rv-chartbeat-config-body>

<script>
dataLayer = [{"u15":"Hickoryhusker","u16":2343732}];

</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{&quot;id&quot;:27,&quot;image_id&quot;:1809929,&quot;url&quot;:&quot;http://indianahsbasketball.homestead.com/&quot;,&quot;position&quot;:1,&quot;site_id&quot;:52,&quot;created_at&quot;:&quot;2016-01-12T10:58:39.663-06:00&quot;,&quot;updated_at&quot;:&quot;2017-03-15T11:34:17.697-05:00&quot;,&quot;image_url&quot;:&quot;https://images.rivals.com/image/upload/f_auto,q_auto,t_ad/ajfo2blekfsbcddpbdag&quot;}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<script src='/javascript/pencil_ad.js'></script>
<script src='/javascript/stream_ad.js'></script>
<script src='/javascript/moments_ad.js'></script>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='/news/member-services'>Help</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
<a class='link' href='/gifts/purchase'>Gift Subscription</a>
</div>
<div class='flexible-links'>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice' data-philter='angular-data-footer'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice' data-philter='angular-copyright-footer'>© 2021 Yahoo. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/basicFooter-f52cf31faa2fb51e14b7d11944f0f0d0be3da6cd4353a61c24a499b6101be6e7.js"></script>

</body>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PCEtLSBCZWdpbiBjb21TY29yZSBUYWcgLS0+Cgo8c2NyaXB0PgogIHZhciBf
Y29tc2NvcmUgPSBfY29tc2NvcmUgfHwgW107CiAgX2NvbXNjb3JlLnB1c2go
ewogICAgYzE6ICIyIiwKICAgIGMyOiAiNzI0MTQ2OSIsCiAgICBjNTogIjIw
MjI3MTk2NTQiLAogICAgYzc6ICJodHRwczovL2hpY2tvcnlodXNrZXIucml2
YWxzLmNvbS9uZXdzL2luZGlhbmEtYmFza2V0YmFsbC1ob2YtYW5ub3VuY2Vz
LTYwdGgtbWVuLXMtaW5kdWN0aW9uLWNsYXNzIgogIH0pOwogIChmdW5jdGlv
bigpIHsKICAgIHZhciBzID0gZG9jdW1lbnQuY3JlYXRlRWxlbWVudCgic2Ny
aXB0IiksIGVsID0gZG9jdW1lbnQuZ2V0RWxlbWVudHNCeVRhZ05hbWUoInNj
cmlwdCIpWzBdOyBzLmFzeW5jID0gdHJ1ZTsKICAgIC8vIGxvYWRpbmcgdGhl
IGV2ZXJncmVlbiB2ZXJzaW9uIG9mIGNzLmpzIHNvIHdlIGFsd2F5cyBoYXZl
IHRoZSBsYXN0IHZlcnNpb24KICAgIHMuc3JjID0gImh0dHBzOi8vcy55aW1n
LmNvbS9jeC92em0vY3MuanMiOwogICAgZWwucGFyZW50Tm9kZS5pbnNlcnRC
ZWZvcmUocywgZWwpOwogIH0pKCk7Cjwvc2NyaXB0PgoKPG5vc2NyaXB0Pgog
IDxpbWcgc3JjPSJodHRwczovL3NiLnNjb3JlY2FyZHJlc2VhcmNoLmNvbS9w
P2MxPTImYzI9NzI0MTQ2OSZjNz1odHRwcyUzQSUyRiUyRmhpY2tvcnlodXNr
ZXIucml2YWxzLmNvbSUyRm5ld3MlMkZpbmRpYW5hLWJhc2tldGJhbGwtaG9m
LWFubm91bmNlcy02MHRoLW1lbi1zLWluZHVjdGlvbi1jbGFzcyZjNT0yMDIy
NzE5NjU0JmN2PTIuMCZjaj0xJmNzX3VjZnI9MCIgLz4KPC9ub3NjcmlwdD4K
PCEtLSBFbmQgY29tU2NvcmUgVGFnIC0tPgoKCg==

</div>
</div>
</html>
